Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Любознайка09
25.05.2020 03:12 •
Информатика
Составить программу на языке паскаль. найдите среднее ариыметическое натуральных чисел от 1 до n кратных 5.
Ответ:
Ернур150400
02.10.2020 15:21
Program z1;
var a:array[1..10000] of longint;
k,i,s,r:longint;
v:real;
begin
read(k);
for i:=1 to k do
read(a[i]);
s:=1;
r:=0;
v:=0;
for i:=1 to k do
if (a[i] mod 5)=0 then begin
s:=s*a[i];
r:=r+1;
end;
v:=s/r;
write(v);
end.
0,0
(0 оценок)
Ответ:
ДарьяКолисан
02.10.2020 15:21
{на основе формулы арифметической прогессии}
var
n: integer;
begin
readln(n);
writeln((5+5+5*(n div 5 -1))/2) ;{((a1+a1+d*(n-1))/2)}
end.
{или перебором без математики}
var
i,n,k: integer;
s:real;
begin
k:=0;
readln(n);
for i:=1 to n do
if i mod 5=0 then begin s:=s+i; k:=k+1; end;
writeln(s/k) ;
end.
Пример
n=100
summa=52.5
0,0
(0 оценок)
Популярные вопросы: Информатика
Tima2005777
13.04.2020 23:57
Впаскале, решить pascal решить через массив, я плохо понимаю массивы. даны числа . получить сумму тех чисел данной последовательности, которые a)кратны 5; б)нечетны и отрицательны;...
МарианнаБелая
13.04.2020 23:57
Сделать программу, которая бы выставляла цифры в порядке возрастания(цифр для проверки будет много) если что язык любой...
HelpPlzzzzz
13.10.2022 18:12
Найдите все натуральные числа,принадлежащие отрезку (101000000;102000000), у которых ровно 3 различных четных делителя. Напишите программу на Паскале или на Питоне....
StasuxaStasyan
15.01.2022 07:06
!написать программу и блок схему. посчитать сумму квадратов нечетных чисел от 1 до 77...
marsik261
02.02.2021 09:03
Какие бывают услуги в интернет (только не алиэкспресс) мне для презентации надо!...
emesiemesi95
19.02.2020 23:19
Напишите программу и блок-схему а=1+3+5++(2n+1)/1*3*5**(2n+1)...
хадЯ66
19.02.2020 23:19
Соберите программу на языке паскаль. вывести на экран сумму цифр целого числа m 0...
talibansky
08.01.2023 11:41
Составить программу : вывести на экран номер первого минимального элемента массива из 15 чисел !...
твоёсолнце7
06.07.2022 13:56
Записать и выражение для объединения областей в диаграмме 1+4+8...
AlekseyLascot
08.07.2020 20:57
Прога dev-c++. фирма набирает сотрудников от 25 до 40 лет включительно. ввести возраст человека и определить, подходит ли он фирме (вывести ответ «подходит» или «не подходит»)....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array[1..10000] of longint;
k,i,s,r:longint;
v:real;
begin
read(k);
for i:=1 to k do
read(a[i]);
s:=1;
r:=0;
v:=0;
for i:=1 to k do
if (a[i] mod 5)=0 then begin
s:=s*a[i];
r:=r+1;
end;
v:=s/r;
write(v);
end.
var
n: integer;
begin
readln(n);
writeln((5+5+5*(n div 5 -1))/2) ;{((a1+a1+d*(n-1))/2)}
end.
{или перебором без математики}
var
i,n,k: integer;
s:real;
begin
k:=0;
readln(n);
for i:=1 to n do
if i mod 5=0 then begin s:=s+i; k:=k+1; end;
writeln(s/k) ;
end.
Пример
n=100
summa=52.5