В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ала213
ала213
24.02.2021 02:21 •  Информатика

Напишите программу, которая показывает количество нечетных чисел в числе. ( если можно, то без программы while и не слишком мудро)

Ответ:
VladSolo
VladSolo
23.07.2020 14:07
Var
  k:longint;
  d,n:integer;
begin
  Write('Введите натуральное число (1-2147483647): ');
  Read(k);
  n:=0;
  while k>0 do begin
    d:=k mod 10;
    k:=k div 10;
    if (d mod 2)<>0 then Inc(n)
  end;
  Writeln('Количество нечетных цифр в числе равно ',n)
end.

Тестовое решение:
Введите натуральное число (1-2147483647): 35632105
Количество нечетных цифр в числе равно 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?