В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
leravseznayka
leravseznayka
29.09.2022 21:20 •  Информатика

Одномерные массивы: составить программу, заполняющую массив, состоящий из n элементов, введенными с клавиатуры целыми числами. требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Ответ:
dalakovadg
dalakovadg
02.10.2020 15:02
Var n:array [1..999] of integer;
a,i,c:integer;
begin
write ('Введите кол-во элементов: ');
readln (a);
c:=0;
for i:=1 to a do
begin
write ('Введите ',i,' элемент: ');
readln (n[i]);
if n[i]<0 then c:=i;
end;
WRITELN;
write ('Введённый массив: ');
for i:=1 to a do
begin
write (n[i],' ');
end;
WRITELN;
if c>0 then writeln ('Индекс последнего введённого отрицательного элемента ',c) else writeln ('Отрицательных элементов не было введено!');
end.

Одномерные массивы: составить программу, заполняющую массив, состоящий из n элементов, введенными с
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?