В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
veronika4848
veronika4848
12.07.2022 10:48 •  Информатика

Нужна с информатикой всего 2 ! много ) напишите программу которая находит минимальное и максимальное среди чётных положительных чисел записанных в файле и выводит результат в другой файл в файле записано не более 100 целых чисел вывести в другой текстовый файл те же числа отсортированные в порядке возрастания

Ответ:
dariyakazakova1
dariyakazakova1
23.07.2020 09:00
Задача 1.
var
  f:Text;
  n,nmax,nmin:integer;
begin
  Assign(f,'input.txt'); Reset(f);
  nmax:=-32786; nmin:=32767; {границы представления integer}
  while not Eof(f) do begin
    Readln(f,n);
    if (n>0) and (n mod 2=0) then
      if nmax<n then nmax:=n
      else
        if nmin>n then nmin:=n
  end;
  Close(f);
  Assign(f,'output.txt'); Rewrite(f);
  Writeln(f,nmin,' ',nmax);
  Close(f)
end.

Задача 2.
const
  m=100; { максимальное количество чисел в файле }
var
  f:Text;
  i,j,n,k:integer;
  a:array[1..m] of integer;
begin
  { читаем данные из файла в массив }
  Assign(f,'input.txt'); Reset(f);
  i:=0;
  while not Eof(f) do begin Inc(i); Readln(f,a[i]) end;
  Close(f);
  n:=i;
  { сортируем массив по возрастанию методом пузырька }
  for i := 1 to n-1 do
    for j := 1 to n-i do
      if a[j] > a[j+1] then
      begin k := a[j]; a[j] := a[j+1]; a[j+1] := k end;
  { заполняем файл из массива }
  Assign(f,'output.txt'); Rewrite(f);
  for i:=1 to n do Writeln(f,a[i]);
  Close(f)
end.

Вложение: пример файла input.txt
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?