В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zontikmily
zontikmily
08.01.2021 04:07 •  Информатика

Нужно написать программу в паскаль. группу детей, приехавшую в оздоровительный лагерь, распределяют по по принципу: с 6 до 7 лет — 5-й отряд; с 8 до 9 лет — 4-й отряд; с 10 до 11 лет — 3-й отряд; с 12 до 13 лет — 2-й отряд; с 14 до 15 лет — 1-й отряд. составить программу, которая позволила бы каждому ребенку определять свой отряд.

Ответ:
АндрейТалалев
АндрейТалалев
02.10.2020 14:44
{1 вариант}
var otr, vozr: byte;
begin
  writeln('введите возраст');
  readln(vozr);
  case vozr do
  6,7: otr:=5;
  8,9: otr:=4;
  10,11: otr:=3;
  12,13: otr:=2;
   14,15: otr:=1;
  end;
 writeln('Ваш отряд', otr);
end.

{2 вариант - более простой}
var otr, vozr: byte;
begin
  writeln('введите возраст');
  readln(vozr);
  otr:=5 - vozr div 2 + 3;
  writeln('ваш отряд', otr)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?