В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Aidanа1307
Aidanа1307
14.11.2020 21:06 •  Информатика

Написать программу, которая заменяет все заглавные буквы строчными, а строчные – заглавными в заданной символьной строке. (паскаль)

Ответ:
Alina3494
Alina3494
02.10.2020 14:32
Program X; //работает только для русских строк
var   
    i: longint;   
    s: string;
begin
    readln(s);
    for i := 1 to length(s) do
        if (ord(s[i]) >= 192) and (ord(s[i]) <= 223) then
            s[i] := chr(ord(s[i]) + 32)
        else if (ord(s[i]) >= 224) and (ord(s[i]) <= 255) then
            s[i] := chr(ord(s[i]) - 32);
    writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?