В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Big1fbfb
Big1fbfb
19.12.2021 09:05 •  Информатика

Составить программу для паскальабс.нет. количество чисел не кратных пяти в указанном диапазоне

Ответ:
егорбаглаев11
егорбаглаев11
22.07.2020 18:23
Program vasha_zadacha_1;
var a,b,c:integer ; 
begin 
c:=0; 
writeln('введите промежуток от'); 
readln(a); 
writeln('до'); 
readln(b); 
if a>b then  
for b:=b to a do begin 
if (b mod 5<>0) then c:=c+1;   
end; 
for a:=a to b do begin   
if (a mod 5<>0) then c:=c+1; 
 end; 
writeln('колличество чисел не кратных пяти в этом диапазоне ', c); 
end.
0,0(0 оценок)
Ответ:
cacalohgf
cacalohgf
22.07.2020 18:23
Var i, a, b, count, crat:integer;
begin
readln(a, b);
for i:=a to b do
begin
crat:=i mod 5;
if crat <> 0 then
begin
count:=count+1
end;
end;
writeln('Количество не кратных = ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?