В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anna3371
anna3371
09.08.2021 20:49 •  Информатика

Pascal abc. дано натуральное число "n". составьте программу которая выводит максимальную цифру этого числа.

Ответ:
zlatochkaluninа
zlatochkaluninа
22.07.2020 17:15
 var   n,m,a : integer; 
begin 
readln (n); 
While n > 0 do   begin   
a := n mod 10;     
if a > m then     
 m := a;   
n := n div 10;   
end; 
writeln (m); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?