В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
30kotenok04
30kotenok04
23.06.2022 15:58 •  Информатика

Паскаль! 1)написать программу ,которая проверяет,является ли число четным или нечетным 2)написать программу,которая проверяет,делится ли на 3 целое число введенное с клавиатуры 3)написать программу,которая определяет ,является билет "счастливым" или нет,билета 6-ти значное число .билет является счастливым,если если сумма первых двух чисел равна сумме трех последних цифр 5)написать программу,которая проверяет ,делится ли на шесть целое число,введенное с клавиатуры 6)написать программу ,определяющую делится ли число b на число a нацело. 7)дано целое 4-х значное число . поменять местами цифры,стоящие в этом числе в разные места,вывести на экран исходное и измененное число

Ответ:
anyaternovskay
anyaternovskay
22.07.2020 15:17
1
program z;
var
    i : integer;
begin
    Writeln('Введите число'); Readln(i);
    if i mod 2 = 0
        then
            Writeln('Число чётное')
        else
            Writeln('Число не чётное');
    readln;
end.

2
program z;
var
    i : integer;
begin
    Writeln('Введите число'); Readln(i);
    if i mod 3 = 0
        then
            Writeln('Число делится на 3')
        else
            Writeln('Число не делится на 3');
    readln;
end.

3
program z;
var
    i: array[1..6] of byte;
    x:byte;
begin
    for x:=1 to 6 do
   
        begin
            Writeln('Введите ', x,' цифру из 6 ');
            Read(i[x]);
        end;
    if (i[1]+i[2]) = (i[4]+i[5]+i[6])
        then
            Writeln('Билет счастливый')
        else
            Writeln('Билет не счастливый');
    Readln;
end.
       
5)))
program z;
var
    i : integer;
begin
    Writeln('Введите число'); Readln(i);
    if i mod 6 = 0
        then
            Writeln('Число делится на 6')
        else
            Writeln('Число не делится на 6');
    readln;
end.
6
program z;
var
    a,b:integer;
begin
    Writeln('Введите число A'); Readln(a);
    Writeln('Введите число B'); Readln(b);
    if b mod a = 0
        then Writeln('Число А делится нацело на число В')
        else Writeln('Число А не делится нацело на число B');
    Readln;
end.
       
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?