В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
denisseleznevdenis
denisseleznevdenis
13.07.2021 21:48 •  Информатика

Вариант а 1) опишите, что выполняет данная программа. пример на конкретных числах: var a,b,s,j: integer; begin read(a,b); s: =0; for j: =a to b do begin s: =s+j; end; write(s); end. 2) напишите программу, которая выводит все четные числа до заданного пользователем числа.

Ответ:
ШАТАНТРУБА
ШАТАНТРУБА
22.07.2020 12:18
1) Программа находит сумму всех чисел от a до b. Например для 3 и 5, она выведет 12

2)
var
    a, i:integer;
begin
    read(a);
    for i := 1 to a do
        if i mod 2 = 0 then
            write(i, ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?