Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
ЯМС
06.05.2022 02:48 •
Информатика
Написать программу вычисления значения выражения: sin2*sin4*sin6*…*sin2n при заданном n (цикл «до»)
Ответ:
badurina92p0cc49
22.07.2020 09:26
Var
n:integer;
x,p:real;
begin
x:=2;p:=1;
writeln('N?');
readln(n);
repeat
p:=p*Sin(x);
x:=x+2;
until x>n*2;
writeln('p: ',p:4:2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Александра894312
24.08.2022 06:09
Распишите решение и дано, в коробке лежат кубики: 10 красных,8 зеленых,5 желтых,12 синих.вычислите вероятность доставания кубика каждого цвета и кол-ва информации при этом будет получен....
leylaevloeva
24.08.2022 06:09
Вкорзине лежат белые и черные шары. среди них 15 черных шаров. сообщение о том, что их корзины достали белый шар, несет 2 бита информации. сколько всего в корзине шаров?...
Настя2017465
13.12.2020 09:00
Даны два простых высказывания: a = «рубль — валюта россии» c = «гривна — валюта сша». выбери истинное высказывание. 1) ¬p 2) a& c 3) неc 4) ¬a выбор только один...
Август228
04.10.2022 21:22
Написать программу на развилку на языке с++ 20...
Sidhfvdksisvejcnswk
22.05.2021 06:02
Добавьте в программу возможность многократного ввода проверяемого числа.//программа определения простого числаimport java.util.scanner; import java.io.ioexception; import static java.lang.math.*;...
алинаарсенова
05.07.2022 05:21
При установке это выскакивает...
axmet2
06.01.2021 06:19
А) примеры, показывающие, как решение реальной сопровождается соответствующими информационными процессами. укажите, как в этих примерах реализуется три выделенных информационных этапа...
GBNMK
19.09.2021 04:28
5 Выбери устройства ввода информацииА) микрофон, мышь, колонкив) монитор, клавиатура, принтерC) сканер, клавиатура, мышьD) монитор, наушники, принтерЕ системный блок, интерактивная...
Vihenka7
23.03.2022 09:25
Твірна конуса дорівнює 6 см і утворює кут 60° із його висотою. 1. Знайдіть висоту конуса (у см).Відповідь.2. Знайдіть об єм конуса V (у см3)....
danilkazaytsev
13.11.2020 15:26
Зачем нужны две синие полоски на глобусе?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n:integer;
x,p:real;
begin
x:=2;p:=1;
writeln('N?');
readln(n);
repeat
p:=p*Sin(x);
x:=x+2;
until x>n*2;
writeln('p: ',p:4:2);
end.