В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Дан двухмерный массив "у" с размерностью n x m если все элементы строки четные, то вывести порядковый номер строки. в паскале написать программу

Ответ:
fdfggdjfikytktjjkykl
fdfggdjfikytktjjkykl
22.07.2020 07:23
Var
  y:array[1..999, 1..999] of integer;
  i, j, n, m:integer;
  chet:boolean;

begin
  randomize;
  readln(n, m);
  //Рандомно заполняем и выводим двумерный массив числами от 0 до 100
  for i:=1 to n do
  begin
    for j:=1 to m do begin
      y[i, j]:=random(101);
      write(y[i, j],' ');
    end;
    writeln;
  end;
  writeln;
  for i:=1 to n do
  begin
    chet:=true;
    for j:=1 to m do
      if y[i, j] mod 2 <> 0 then
        chet:=false;
    if chet = true then
      write(i, ' ');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?