В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу. вводится число n, а затем n чисел. определить сумму отрицательных двузначных чётных чисел.

Ответ:
bedboy777
bedboy777
02.10.2020 12:58
Program a;
var n,sum,i,s: integer;
begin
  readln(n);
  for i:=1 to n do
      begin
           read(s);
           if (s<0) and ((s div 10)>-10) and ((s div 10)<>0)  and ((s mod 2)=0) then sum:=sum+s;
      end;
   writeln (sum);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?