В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Maria590986
Maria590986
08.06.2023 18:37 •  Информатика

Написать программу с организацией ввода-вывода с текстовых файлов. в каждой задается квадратная матрица nxn. программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.

Ответ:
Lizak11
Lizak11
26.05.2020 02:42

var a:array[1..10,1..10]of integer;
i,j,k,s:integer;
begin
for i:=1 to 10 do for j:=1 to 10 do a[i,j]:=random(9)+1;
for i:=1 to 10 do begin for j:=1 to 10 do write(a[i,j],' '); if j=10 then writeln; end;
s:=1;
for i:=2 to 10 do begin k:=a[i,1];
for j:=2 to 10 do begin
if i mod 2 = 0 then if a[i,j]>k then k:=a[i,j];
if (j=10) and (i mod 2=0) then s:=s*k;
end;
end;

writeln(s);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?