В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
annablakfare303030
annablakfare303030
02.06.2022 08:52 •  Информатика

Язык программирования: паскаль. написать программу. заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую – по убыванию.

Ответ:
roman20031022
roman20031022
07.06.2020 03:42

var a:array[1..10]of integer;
i,j,k:integer;
begin
for i:=1 to 10 do a[i]:=random(101);
for i:=1 to 10 do write(a[i],' ');
writeln;


for i:=1 to 5 do
for j:=1 to 4 do
if a[j]>a[j+1] then begin
k:=a[j];
a[j]:=a[j+1];
a[j+1]:=k;
end;

 

for i:=1 to 5 do
for j:=7 to 10 do
if a[j]>a[j-1] then begin
k:=a[j];
a[j]:=a[j-1];
a[j-1]:=k;
end;

 

for i:=1 to 10 do write(a[i],' ');


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?