В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Olya199701
Olya199701
01.04.2020 11:11 •  Информатика

Составить программу чисел кратных 7 и 11 от 144 до 1000 (найти сумму и их количество) ))

Ответ:
bozenka20042004
bozenka20042004
26.05.2020 02:29

var i,s,n:integer;
begin
for i:=144 to 1000 do if (i mod 7=0) or (i mod 11=0) then begin s:=s+i; n:=n+1; end;
writeln(s,' ',n);
end.

0,0(0 оценок)
Ответ:
lelyashramkop028pw
lelyashramkop028pw
26.05.2020 02:29

program skype:van4es007;
var s,i,d,s1,d1,j:integer;
begin
s:=0;
s1:=0;
d:=0;
d1:=0;
for i:=144 to 1000 do
if (i mod 7 = 0) then begin
s1:=s1+1;
s:=s1*7
end;
for j:= 144 to 1000 do
If (j mod 11 = 0) then
begin
d1:=d1+1;
d:=d1*11
end;

     {sum:=d+s;

      sum1:=d1+s1;

writeln('общая сумма чисел ='sum);  вроде не обязательно}

writeln('общее количество чисел ='sum1); это тоже,если надо то добавь sum и sum1 }

writeln('сумма чисел кртаных 7 =',s);
writeln('всего чисел кратных 7,в заданом промежутке =',s1);
writeln('сумма чисел кртаных 11 =',d);
writeln('всего чисел кратных 11,в заданом промежутке =',s);

readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?