Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
KiskaDasha
03.03.2020 11:42 •
Информатика
Язык программирования - паскаль ввести целое число и определить количество цифр в нем. так же дан алгоритм: отсекаем последнюю цифру, при этом увеличиваем счетчик на единицу. надо остановиться, пока n< > 0. буду (:
Ответ:
hahahagall
02.10.2020 12:33
Var
n,i : integer;
begin
readln(n);
i := 0;
while(n <> 0) do
begin
n := n div 10;
i := i+1;
end;
Writeln(i);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
alenasamok
16.07.2022 16:40
Менеджер находится в командировке. ему необходимо важную для фирмы информацию. в его распоряжении находится только флешка, на которую можно поместить 16 гбайт. на носителе...
arinka200000
13.08.2021 00:39
Выражение 93 +4 – 1.строковое 2.арифметическое 3.логическое...
89000566004
01.06.2022 02:24
Дано трёхцифрове число.знайти добуток першої та третьої цифри цього числа....
rano124
22.02.2022 08:11
Введите делимое и делитель. нужно посчитать сколько раз произойдет деление. , , надо. 25...
Alica2653
08.09.2020 20:44
Дана иерархическая система папок в опирационной системе виндовс запишите полные имена файлов...
ник4858
22.09.2020 07:43
напишите ответ как можно быстрей! Выше приведена программа, записанная на языке программирования Паскаль. Было проведено 9 запусков программы, при которых в качестве значений...
mukhamedinaguls
08.03.2022 18:56
Переведите десятичное число 225 в восьмеричную систему счисления. В ответ запишите только восьмеричное число, основание системы записывать НЕ нужно...
HETHEDAM
31.07.2021 11:21
Словосочитание к словам: антидемократичный,антигуманный,антиморольный,антинародный, пейзаж,пейзажный,пейзажист,справедливый,справедливость,употреблять,употребление,употреблительный....
ЯестьПаша
31.07.2021 11:21
Напишіть твір гостинність українців...
andrianovva
26.12.2020 18:29
Напишите ответ на вопрос: кто виноват в смерти фортунато из новеллы п.мериме маттео фальконе ? как на этот вопрос отвечает автор? не списывать, писать самому....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n,i : integer;
begin
readln(n);
i := 0;
while(n <> 0) do
begin
n := n div 10;
i := i+1;
end;
Writeln(i);
end.