В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lrada123
lrada123
27.04.2020 01:25 •  Информатика

Составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.

Ответ:
Tomoki
Tomoki
21.07.2020 15:52
 var   
a,b,c,g : integer;   
// a,b,c - стороны         
begin 
readln (a,b,c);   

// g - находим гипотенузу (наибольшее из чисел) 
if a > b then   
begin   
if a > c then     
g := a   
else     
g := c   
end 
else   
if b > c
then   
g := b   
else   
g := c;   

// Если треугольник прямоугольный, то 
// сумма квадратов катетов равна квадрату гипотенузы      

if (sqr (a) + sqr (b) = sqr(g)) 
or (sqr (a) + sqr (c) = sqr(g)) then   
writeln ('Yes')   
else    writeln ('No');
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?