В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ksu26082002
ksu26082002
14.10.2021 12:53 •  Информатика

Составить программу в паскаль: дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.

Ответ:
анюта606
анюта606
21.07.2020 12:09
Var b,a,c,kol:integer;
 begin 
writeln('введите число в десятичной системе счисления');
 readln(a); 
 kol:=0; 
 while(a>=2) do  begin 
      c:=a div 2; 
      b:=2*c; 
      b:=a-b; 
      writeln(b); 
      a:=c; 
     if a<2 then 
     writeln(a); 
     if a > 0 then 
     kol:=kol+1; 
end; 
writeln('количество 'kol);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?