Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
olga170103
09.07.2020 09:54 •
Информатика
Решить на дан массив x(t). вычислить сумму положительных элементов массива с номерами меньшими 7, значение которых больших 15 (t³7) .
Ответ:
alechka7
21.07.2020 10:22
Const t=10;
var
x: array [1..t] of integer;
s, i: integer;
begin
for i:=1 to t do
begin
x[i]:=random(51)-20;
writeln('x[', i, '] = ', x[i]);
if (x[i]>0) and (i<7) and (x[i]>15) then s:=s+x[i];
end;
writeln('Сумма равна ', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
savitar228
12.05.2022 22:07
A1*a2/d2/d3 запишите в традиционной форме...
Котейко444
21.12.2021 15:24
3. Определите информационный объем символов, если мощность алфавита составляет 32 буквы. 5 7 4 2...
po4emy228
10.03.2021 23:13
О каких функциях идет речь...
epincessg11
09.06.2020 16:58
Информационный объем жесткого диска 209 715 200 байтов выразить в гигабайтах....
vikasss1581
11.03.2023 07:19
с решением задачи на Pascal) Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = n*n*n + n*n + 1, при n...
gudroonnp010ou
19.05.2020 11:48
Сочинение по книги пушкина дубровский...
hope903
19.05.2020 11:48
Втреугольнике abc угол с равен 90 градусов,ac-8,cos a=0,8.найдите длину стороны bc....
Kira2347
19.05.2020 11:48
По дорожке стадиона длиной 400 м из одной точки одновременно в одномнаправлении выбегают три спортсмена со скоростями 12 км/ч, 15 км/ч и 17 км/ч.найдите, через какое...
anuar0403
19.05.2020 11:48
Напрочь все забыла.. cos^2 15+ cos^2 75 ответ 1...
OppLeech
19.05.2020 11:48
Краткое содержание(5 предложений) произведения о любви чехова,и изобразительные средства в произведении: )...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
x: array [1..t] of integer;
s, i: integer;
begin
for i:=1 to t do
begin
x[i]:=random(51)-20;
writeln('x[', i, '] = ', x[i]);
if (x[i]>0) and (i<7) and (x[i]>15) then s:=s+x[i];
end;
writeln('Сумма равна ', s);
end.