В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
shishovtopking
shishovtopking
09.01.2022 13:24 •  Информатика

Составить программу(10класс): дано предложение,заменить в нем все запятые на точки и удалить из предложения подстрочку по запросу пользователя.

Ответ:
arm21
arm21
02.10.2020 11:55
uses Crt;
 var  Stroka, PodStroka: string;
     poz, i: integer;
begin
 ClrScr;
 Write(' Stroka :   '); ReadLn (Stroka);
 for i:= 1 to length (Stroka) do
     if Stroka[i]=',' then Stroka[i]:='.';

 WriteLn(' Zamena :   ', Stroka);
 WriteLn;
 Write(' PosStroka :   '); ReadLn (PodStroka);
 poz:=Pos(PodStroka, Stroka);
 Delete (Stroka,poz,length(PodStroka));
 WriteLn(' Udalili :   ', Stroka);
 ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?