В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
leylamagomedov2
leylamagomedov2
28.02.2020 16:04 •  Информатика

Написать программу с цикла с предусловием (while). вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.

Ответ:
12233454647758886776
12233454647758886776
02.10.2020 11:49
// F#
open System
[<EntryPoint>]
let main argv =
    let mutable sum = 0
    let mutable i = 0
    let array = [19..51]
    while i < array.Length do
        let value = array.Item i
        if 5 % value = 0 then
             sum <- sum + value
        i <- i+1
    Console.WriteLine sum
    Console.ReadKey true |> ignore
    0

// Pascal (for)
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 0;
  for i:=19 to 51 do
  begin
    if i mod 5 = 0 then
      sum := sum + i;
  end;
  writeln(sum);
end.

// Pascal
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 19;
  while (i <= 51) do
  begin
    if i mod 5 = 0 then
      sum := sum + i;
    i := i + 1;
  end;
  writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?