В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
iamash2450
iamash2450
01.02.2021 05:36 •  Информатика

Составить программу, которая спрашивает: "кто это, кошка или собака? ". в зависимости от ответа ("к" или "с"), печатает на экране: "мяу-мяу! " или "гав-гав

Ответ:
жандосЕУ
жандосЕУ
20.07.2020 23:18
//Pascal
var 
 x:char;
begin
 writeln('Кто это, кошка или собака?');
 readln(x);
 if x = 'К' then
  writeln('Мяу-мяу!');
 if x = 'C' then
  writeln('Гав-гав!');
end.
0,0(0 оценок)
Ответ:
ARMY130613
ARMY130613
20.07.2020 23:18
// F#
open System;
[<EntryPoint>]
let main argv =
    let rec getResult _ =
        let answer = Console.ReadKey(true);
        match answer.KeyChar with
            | 'К' | 'к' -> "Мяу-мяу!"
            | 'С' | 'с' -> "Гав-гав!"
            | _ -> (getResult null)
    printf "Это кошка или собака?\n"
    printf "%s" (getResult null)
    0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?