В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
CCQ
CCQ
19.02.2023 17:40 •  Информатика

Написать программу обмена переменных x и y , без использования дополнительных велечин , ( это надо делать в pascal)

Ответ:
natik49
natik49
20.07.2020 20:28
Var
  a,b:integer;
begin
  a:=50; b:=-20; { начальное присванивание }
  Writeln('Исходные значения: a=',a,', b=',b);
  a:=a+b; b:=a-b; a:=a-b;
  Writeln('Обмен после "арифметического"
  a:=50; b:=-20; { начальное присванивание }
  a:=a xor b; b:=a xor b; a:=a xor b;
  Writeln('Обмен после "логического"
end.

Результат выполнения программы:
Исходные значения: a=50, b=-20
Обмен после "арифметического"
Обмен после "логического"
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?