В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
annatiko1984
annatiko1984
23.02.2021 09:09 •  Информатика

На pascal: на вход программы значения элементов трех целочисленный массивов: , , (n< =40). написать программу которая выводит на экран слово "да", если отрицательный элемент в массиве с встречается раньше, чем в массивах а и в. в противном случае на экран должно быть выведено слово "нет". предполагается, что каждый из массивов содержит хотя бы один отрицательный элемент. заранее !

Ответ:
BEAR58
BEAR58
02.10.2020 11:34

program raf105;

const

 n = 35;

var

 a: array[1..30] of integer;

 b: array[1..40] of integer;

 c: array[1..n] of integer;

 i : integer;

begin

 writeln('Заполните массив A');

 for i:=1 to 30 do

   readln(a[i]);

   

 writeln('Заполните массив B');

 for i:=1 to 40 do

   readln(b[i]);

   

 writeln('Заполните массив C');

 for i:=1 to n do

   readln(c[i]);

   

 for i:=1 to 40 do

 begin

   if (a[i] < 0) or (b[i] < 0) then

     begin

       writeln('Нет');

       break

     end;

   if c[i] < 0 then

     begin

       writeln('Да');

       break

     end;

 end;

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?