В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LilauSen
LilauSen
16.06.2022 12:34 •  Информатика

Нужно решить 2 по информатике: 1) дан массив b[1..10] составьте программу которая находит количество элементов, которые больше своего соседа слева 2) дан массив b[1..10] составьте программу которая находит количество пар элементов с четным значением

Ответ:
стас2118
стас2118
02.10.2020 11:02
Вот решение первой задачки:

program Sosed;
uses Crt;
const n = 10;
type  Vec = array [1..n] of integer;
var  A: Vec;
     i, Col: integer;
begin
 ClrScr;
 Randomize;

 WriteLn('Massiv A:');
 for i:=1 to n do
     begin
        A[i]:= 10+random (90);
        Write (A[i]:4);
     end;
 WriteLn;
 Col:=0;
 for i:=2 to n do
   begin
     if A[i]<A[i-1] then
       Col:=Col+1;
   end;
 WriteLn;
 if Col<>0 then  Writeln('Col =', Col)
           else WriteLn('None!');
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?