В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
frankinshtein228
frankinshtein228
29.02.2020 02:10 •  Информатика

Составьте программу для решения следующей . дано четырехзначное число. определить делится ли это число на все свои цифры.

Ответ:
lemyana2017
lemyana2017
20.07.2020 15:18
Program zadacha;
var a,b,c,d,e: integer;
begin
writeln ('Введите четырехзначное число');
readln (a);
b:=a div 1000;
c:=a div 100;
c:=c mod 10;
d:=a mod 100;
d:=d div 10;
e:=a mod 10;
if (a mod b = 0) and (a mod c = 0) and (a mod d = 0) and (a mod e = 0) then writeln ('Число делится на все свои цифры')
else writeln ('Число не делится на все свои цифры');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?