В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ksenchhh
ksenchhh
12.01.2020 01:17 •  Информатика

Написать программу на языке си++ в целочисленном массиве в (4,3) заменить все его элементы их квадратами

Ответ:
szelenkooz1uqs
szelenkooz1uqs
20.07.2020 13:47
#include <iostream>
#include <cstdlib>

using namespace std;

int main() {
    int i,j;
    int a[4][3];
    for (i=0; i<4; i++){
        cout<<"Stroka "<<i+1<<endl;
        for (j=0; j<3; j++) {
            cout<<"Element "<<j+1<<": ";
            cin>>a[i][j];
        }
        cout<<endl;
    }
    cout<<"Resul'tat"<<endl;
    for (i=0; i<4; i++) {
        for (j=0; j<3; j++) {
            a[i][j]*=a[i][j];
            cout<<a[i][j]<<" ";
        }
        cout<<endl;
    }
    cin>>i; //ïðîñòî ÷òîáû ýêðàí íå çàêðûëñÿ
    return 0;
}

Тестовое решение (Dev C++)
Stroka 1
Element 1: 1
Element 2: 2
Element 3: 3

Stroka 2
Element 1: 4
Element 2: 5
Element 3: 6

Stroka 3
Element 1: 7
Element 2: 8
Element 3: 9

Stroka 4
Element 1: 10
Element 2: 11
Element 3: 12

Resul'tat
1 4 9
16 25 36
49 64 81
100 121 144:
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?