Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Наташа123454321
21.07.2022 05:20 •
Информатика
Паскаль даны четыре целых числа. найти сумму четных и нечетных чисел.
Ответ:
arina556
20.07.2020 07:25
Var
a: array [1..4] of integer;
i, sf, ss : integer;
begin
for i:=1 to 4 do
begin
a[i]:= random(50)+1;
writeln(a[i]);
if a[i] mod 2 = 0 then sf:=sf+a[i] else
ss:= ss+a[i];
end;
writeln('Сумма четных: ', sf, ' ; сумма нечетных: ', ss);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
polinapolina22
22.04.2021 05:45
даны два различных числа если первое число больше второго , то уменьшить каждое число в 4 раза, иначе увеличить в 3 раза. вывести результат...
Jastick
20.06.2020 10:47
Отсортируйте массив по возрастанию. Программа на языке Python...
andrejpuzanov90
03.12.2021 15:22
Написать программу на нахождения суммы (Python) c=a+b...
belovavaleriya
09.08.2022 05:44
Напишите программу, которая выводит на экран числа от 0 до 8, кроме 2 и 5программирование...
ПтичкаСоловей
30.09.2021 13:31
Ведите алфавит двоичной системы...
Neznat13
01.08.2022 19:19
Задание 4. Задана кодовая информация в виде ряда чисел. 1) Декодируй эту информацию и запиши ответ: 23 27 25 28 43 45 32 16 29 2) Закодируй слово ИНФОРМАТИКА...
81810000
20.06.2021 23:46
с заданием: Какие макеты использованы для каждого слайда и почему?:...
булати
21.08.2020 13:23
Перевезення роялю остаточно поламали ліфт, і тепер він їздить на кожен четвертий поверх. Визначити вартість доставки роялю за нових умов. Потрібно написати код в pyhton...
panevin33vladik
17.11.2021 22:51
Линейные алгоритмы. Задача 2.9 Дано натуральное четырехзначное число N. Определить число, полученное перестановкой разрядов десятков и сотен исходного числа. Формат входных...
saparchikrusoy10t7
20.01.2022 13:04
Выразите углы в долях П: 135о, 35о , 90о . Переведите углы в градусную меру: 7п/6, 3п/4, 10п.Определить в какой четверти лежит данный угол: 90о ,180о,105о,296о...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a: array [1..4] of integer;
i, sf, ss : integer;
begin
for i:=1 to 4 do
begin
a[i]:= random(50)+1;
writeln(a[i]);
if a[i] mod 2 = 0 then sf:=sf+a[i] else
ss:= ss+a[i];
end;
writeln('Сумма четных: ', sf, ' ; сумма нечетных: ', ss);
end.