В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
didlok
didlok
30.03.2022 03:18 •  Информатика

Написать программу на языке c/c++, которая принимает на вход: 1. n целочисленных элементов, где n = 5 + (k mod 5). здесь k=10. n можно задавать равным конкретному числу прямо внутри программы. 2. целое число a (после того, как считали n чисел). найдите индекс (порядковый номер) первого числа (из введенных n чисел), равного a. если такого числа нет, выведите соотв. сообщение (например, “no number a”). написать данную программу с использованием конструкции if, цикла for, используйте массив. использование команды goto запрещено. подсказка: заведите целочисленный массив, соответствующий вашему варианту (т.е числу n), например, int savednumbers[7]; в цикле считывайте очередное целое число, пишите его в массив. после считки всех чисел и окончания цикла считайте число a. ещё раз пройдите по массиву и найдите первое вхождение a, если оно есть.

Ответ:
frolikoffgrigory
frolikoffgrigory
20.07.2020 06:47
#include <stdio.h>

int main() {
    const int k = 10;
    int n = 5 + k % 5;
    int savedNumbers[n];
    for (int i = 0; i < n; i++) {
        scanf("%d", &savedNumbers[i]);
    } 
   int a;
   scanf("%d", &a);
   for (int i = 0; i < n; i++) {
        if (a == savedNumbers[i]) {
            printf("First in - %d.", i + 1);
            return 0;
        } 
   }
    printf("No number A.");
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?