В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
maynovetskaya0
maynovetskaya0
07.07.2020 12:40 •  Информатика

Нужна по информатике. : написать программу вычислить произведение из двух наибольших введенных с клавиатуры чисел.( в паскале). проще говоря, у меня есть три числа, я должен ввести их, и два наибольших из них должны перемножаться. нужно написать программу используя условные операторы. заранее .

Ответ:
Даша2002111111
Даша2002111111
20.07.2020 01:59
Var
  a,b,c:integer;
begin
  Write('Введите три целых числа: '); Readln(a,b,c);
  if a>b then
    if b>c then Writeln(a*b) else Writeln(a*c)
  else
    if a>c then Writeln(a*b) else Writeln(b*c)
end.

Тестовое решение:
Введите три целых числа: 5 -2 7
35
0,0(0 оценок)
Ответ:
Алёнажж
Алёнажж
20.07.2020 01:59
Var m: array [1..3] of real;
var i, imin, imax: integer;
var num, pro: real;
begin
imin:=1;
imax:=1;
for i:=1 to 3 do read (m[i]);
for i:=1 to 3 do  
begin 
if m[i]<m[imin] then imin:=i; 
if m[i]>m[imax] then imax:=i; 
end;
num:=m[1]+m[2]+m[3]-m[imin]-m[imax];
pro:=num*m[imax];
write (pro);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?