В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nosalyaik
nosalyaik
16.12.2020 03:07 •  Информатика

Составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом r и началом в точке o(a,b) хотя бы примерно

Ответ:
summani2005
summani2005
26.05.2020 00:14

var

 x, y, R, Oa, Ob: real;

 

begin

  writeln('Введите радиус окружности R');

  readln(R);

  writeln('Введите координаты центра окружности');

  readln(Oa, Ob);

  writeln('Введите координаты точки');

  readln(x, y);

  if (x > (Oa - R)) and (x < (Oa + R)) and (y  > (Ob - R)) and (y < (Ob + R)) then

    writeln('Точка с заданными координатами лежит внутри круга')

  else

    writeln('Точка с заданными координатами лежит вне круга');

end. 

Если все правильно, отметь решение как лучшее)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?