В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hatechanoy23l1
hatechanoy23l1
14.11.2021 02:27 •  Информатика

Написать программу с++ "дано трех значное число, необходимо найти старшую цифру и вывести на экран надпись , какая из цифр наибольшая "

Ответ:
Андріана1323
Андріана1323
19.07.2020 23:13
#include <iostream>
using namespace std;
int main()
{
 int n,m,p;
 cin>>n;
 int n1=n/100;
 int n2=(n/10)%10;
 int n3=n%10;
 if (n1>n2)
    if (n1>n3) {m=n1; p=1;} else {m=n3; p=3;}
 else
    if (n2>n3) {m=n2; p=2;} else {m=n3; p=3;}
 cout<<"max="<<m<<", poz= "<<p<<endl;
 system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?