В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
savichc
savichc
08.06.2023 19:31 •  Информатика

Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (паскаль)

Ответ:
EgrVir2018
EgrVir2018
02.10.2020 09:59
Var mas30: array [1..30] of integer;
var i, proz: integer;
begin
proz:=1;
for i:=1 to 30 do  begin mas30[i]:=-5+random (11); //Заполнение массива 
write (mas30[i], '  '); //вывод значений массива 
end; 
writeln;
for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; //Подсчет произведения отриц элементов
writeln (proz);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?