Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
NikolayNik12
29.05.2020 04:34 •
Информатика
Написать программу на языке си .1. подсчитать количество прописных букв в строке. 2. удалить из строки самое длинное слово.
Ответ:
Cardboard
19.07.2020 19:39
Написать програму которая считывает текст с клавиатуры, находит самое длинное число и определяет, сколько раз оно встретилось в тексте.
Код C++
#include <conio.h>
#include <stdio.h>
#include <string.h>
#include <iostream.h>
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<<endl<<endl;
gets(s);
p=strtok(s,s1);
while(p)
{if(*p==' ')
p=strtok(s,s1);
g=strlen(p);
cout<<endl<<g<<endl;
if(a<g)
{a=g;
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<<endl<<e;
getch();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
halimattek
15.03.2022 07:13
Приведите примеры использования машинного обучения....
yuliatimofeewap08u9q
02.01.2022 11:37
ЯЗЫК ПИТОН Напиши программу для сохранения списка дел на день.Сначала программа должна запрашивать количество предполагаемых дел. Затем в цикле (соответствующее количество...
кристина2162
08.02.2022 08:00
3. Как называется плоский объект, ограниченный ребрами? А) ТочкаБ) 2DВ) 3DГ) Не существует...
димкаа2
03.11.2022 14:08
1. Браузер – это а) программа просмотра гипертекстовых документовб) компьютер, подключенный к сетив) главный компьютер в сетиг) Устройство для подключения к сети2....
igor2285
04.01.2021 08:42
Согласно атрибутивной концепции, … информация возникла вместе со Вселенной информация появилась с возникновением жизни информация – признак, отделяющий живое от неживого...
robertva693
02.02.2021 04:14
Ежедневник – это… 1. носитель внутренней памяти 2. носитель внешней памяти ОТВЕТ:...
Vera20000
22.03.2022 08:43
Скорость передачи данных через модемное соединение 28Кбит/с. Передача текстового файла заняла 10 с. Сколько символов содержал переданный текст, если известно, что он...
NiceLeave
18.04.2021 17:44
Квадратний тричлен розкладено на множники: 5x² – 23х – 10 = 5(х – 5) (х – а). Знайдіть значення а....
ученик6бкласса
18.04.2021 17:44
Составь на неделю План конкретных Домашних дел, с которыми ты справишься самостоятельно. План MО-жет быть составлен с несложных рисунков,В конце недели подведи итоги...
Анастасия2787
23.06.2022 09:58
Пестливі слова в творі химерний малнький...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Код C++
#include <conio.h>
#include <stdio.h>
#include <string.h>
#include <iostream.h>
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<<endl<<endl;
gets(s);
p=strtok(s,s1);
while(p)
{if(*p==' ')
p=strtok(s,s1);
g=strlen(p);
cout<<endl<<g<<endl;
if(a<g)
{a=g;
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<<endl<<e;
getch();
}