В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MCREW
MCREW
25.10.2020 05:11 •  Информатика

Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. изображение одного флага имеет размер 4×4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец. разрешается вывести пустой столбец после последнего флага. внутри каждого флага должен быть записан его номер — число от 1 до n. входные данные 1 выходные данные + |1 / |__\ | паскаль. нужно использовать фор.

Ответ:
alexlol228
alexlol228
19.07.2020 17:54
Var 
 i,n:integer;
begin 
  read(n); 
  for i:=1 to n do   
   write('+___ '); 
  writeln; 
  for i:=1 to n do 
    write('|',i,' / '); 
  writeln; 
  for i:=1 to n do   
   write('|__\ '); 
  writeln; 
 for i:=1 to n do 
    write('|    ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?