В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
serikovvlad19
serikovvlad19
12.02.2023 04:01 •  Информатика

Написать программу на языке паскаль при подпрограммы функции которая вычисляет минимальное из чисел a b c d

Ответ:
losp
losp
19.07.2020 17:27
PascalABC.NET

type    mass = array [1..4] of integer;

var   a : mass;   
i : integer; 

function min(c : mass) : integer;   
var   
i,minim : integer; 
begin   
minim := c[1]; 
 for i := 2 to 4 do 
  if c[i] < minim then   
  minim := c[i]; 
result := minim;   
 end;  

begin 
 for i := 1 to 4 do 
  readln (a[i]); 
writeln ('min = ',min(a)); 
end.

Как параметр я использовал массив из четырех элементов. Можно использовать просто переменные и через IF все прописать
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?