В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Джміль
Джміль
27.08.2020 02:54 •  Информатика

Напишите программу, которая заполняет с клавиатуры массив а(3,3) словами разного размера и заменяет самое короткое слово главной диагонали на максимальное по длине слово всего массива. выведите на экран исходный и полученный массивы.

Ответ:
Ponchic2201
Ponchic2201
19.07.2020 11:18
PascalABC.NET

const   
 n = 3;      
var   
a : array [1..n,1..n] of string;   
smax : string;   
i,j,lmin,lmax,km : integer; 
  
begin 
lmax := 0; 
smax := '';
    
for i := 1 to n do   
for j := 1 to n do   
begin     
readln (a[i,j]);     
if Length (a[i,j]) > lmax then       
begin       
smax := a[i,j];       
lmax := Length (a[i,j]);       
end;          
end;
    
lmin := Length (a[1,1]); 
km := 1;
 
for i := 2 to n do   
if Length (a[i,i]) < lmin then   
begin     
lmin := Length (a[i,i]);     
km := i;   
end; 
       
writeln (); 
for i := 1 to n do   
begin   
for j := 1 to n do     
write (a[i,j],' ');   
writeln ();   
end; 
writeln ();    
for i := 1 to n do   
begin   
for j := 1 to n do     
if (i = km) and (j = km) then     
write (smax,' ')     
else     
write (a[i,j],' ');   
writeln ();   
end;    
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?