Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
kochergaki2000
29.03.2020 00:31 •
Информатика
Реализовать программу исследования квадратного уравнения . коэффициенты a, b и c вводятся с клавиатуры на языке си++
Ответ:
lushkina73
19.07.2020 10:53
#include <iostream.h>
#include <math.h>
int main()
{
int a, b, c;
long long d;
cout << "Vvedite a: "; cin >> a;
cout << "\nVvedite b: "; cin >> b;
cout << "\nVvedite c: "; cin >> c;
d = b * b - 4 *a * c;
if (d > 0) cout << "x1 = " << (-b + sqrt(d))/(2*a) << "\n" << "x2 = " << (-b - sqrt(d))/(2*a) << endl;
else if (d == 0) cout << "x = " << -1.*b/(2*a) << endl;
else if (d < 0) cout << "Korney net" << endl;
system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
anna199015
16.04.2022 14:48
даю 15 б.дам еще гиперссылка...
supermosyagina
16.04.2022 14:48
Надо написать 2-3 предложения о лошадей.зароние...
fake23
23.02.2020 06:40
Решите на Python 3.81. Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число.2. Дано трехзначное число. Определить, какая...
алькамалька
11.10.2022 07:45
ОТВЕТЬТЕ НА ВО От чего зависит качество звука? 1.Частоты обновления экрана 2. Разрядности 3. От установленного проигрывателя 4.Частоты дискретизации 2) Важная особенность мультимедиа...
Yulia2107
01.08.2022 17:48
Напишите программу на языке программирования Phyton по следующему псевдокоду...
Маша270902
05.02.2020 05:04
K=(x2+y2)*x+y, мұндағы функцияның мәнін есептейтін программа құру керек (Pascal) ...
vovanharahashyox7cel
17.04.2022 00:26
Язык программирования -python задача 1. Напишите программу, которая должна найти среди трех чисел, минимальное четное. Задача 2. Напишите программу, которая должна определить, пройдет...
syltanchik1338
28.02.2022 21:03
Почему моделька игрока в кс го двигается но анимации на ноги нет (сёрфит)? Это чит какой то?...
КаРаТиСтКиОкУшИнА
27.12.2020 10:49
Як відомо, Чебурашка потрапив з тропічного лісу в місто в ящику з апельсинами та жив у телефонній будці. Після знайомства з крокодилом Геною та Галею вони вирішили побудувати будинок...
mssinkevichna
05.01.2020 17:18
Вывести с клавиатуры значения действительных переменных x,y,z. присвоить логической переменной в значение: а) каждое из чисел x,y,z положительно б) по крайней мере одно из чисел...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <math.h>
int main()
{
int a, b, c;
long long d;
cout << "Vvedite a: "; cin >> a;
cout << "\nVvedite b: "; cin >> b;
cout << "\nVvedite c: "; cin >> c;
d = b * b - 4 *a * c;
if (d > 0) cout << "x1 = " << (-b + sqrt(d))/(2*a) << "\n" << "x2 = " << (-b - sqrt(d))/(2*a) << endl;
else if (d == 0) cout << "x = " << -1.*b/(2*a) << endl;
else if (d < 0) cout << "Korney net" << endl;
system("pause");
return 0;
}