Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
nekit2409
13.09.2021 22:16 •
Информатика
Написать программу на паскале: вычислить 15 значений функции y=2-sin x из диапазона [pi/4, pi/2]
Ответ:
HDHDvdvsvvs
19.07.2020 10:20
Const
pi=3.14159265;
n=15;
var
a,b,h,x,y:real;
begin
a:=pi/4; b:=pi/2;
h:=(b-a)/(n-1);
x:=a;
while x<=b+h/2 do { h/2 - компенсация накопления погрешности }
begin
y:=2-sin(x);
Writeln(x:7:5,y:8:5);
x:=x+h
end
end.
Результат выполнения программы:
0.78540 1.29289
0.84150 1.25436
0.89760 1.21817
0.95370 1.18444
1.00980 1.15328
1.06590 1.12478
1.12200 1.09903
1.17810 1.07612
1.23420 1.05612
1.29030 1.03908
1.34640 1.02507
1.40250 1.01413
1.45860 1.00629
1.51470 1.00157
1.57080 1.00000
0,0
(0 оценок)
Популярные вопросы: Информатика
avramkata81
18.09.2022 07:02
Надо , решите ! тема-логические операции (используя логич.умножение и сложение) расписать (avb c черточкой наверху)λa с черточкой наверху...
Nady0208
18.09.2022 07:02
1. для чего люди представляют информацию на материальным носителе? 3 примера из своей жизни 2. преобразования информации и собственого опыта 3. пример преобразования формы предстовления...
SadPlayer007
18.09.2022 07:02
В8 классе в понедельник и пятницу -5 уроков, во вторник и четверг -6 уроков, а в среду -7 уроков. введите номер дня недели. выведите количество уроков в этот день....
olesiadukova
07.04.2022 03:01
Объектами изучения в информатике являются: (может быть несколько вариантов ответа! ) разработка дизайна ноутбука аппаратное и программное обеспечение информационный процесс развитие...
Babl11
11.11.2021 20:14
35 сделайте с ! проводится две лотереи: «6 из 36» и «5 из 64». сообщение о результатах какой из лотерей несет больше информации? повторяю мне надо решение данной и ответ...
vlada23912
09.04.2022 22:40
Выполните арифметическую операцию сложения чисел 110 и 100. решение столиком. заранее ! ...
wut123
25.04.2022 10:10
Для хранения 512 цветного изображения на кодирование одного пикселя выделяется......
gen1978
19.06.2020 06:56
Информатика: миша плавал в бассейне размером n*m метров и устал. в этот момент он обнаружил, что находится на расстоянии х метров от одного из длинных бортиков. (не обязательно от...
ayperi2
06.02.2021 05:29
ответить на вопросы 1. what furniture is there in your flat? 2. what piece of furniture would you like to have in your room? 3.when do you have dinner? 4. what don t you like to eat?...
Goodok10
06.02.2021 05:29
Кролик за день съедает 3 кг 500г кормов из них составляет 7\10 а зерно 7\100 всех кормов сколько вместе травы и зерна съедает кролик за день...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
pi=3.14159265;
n=15;
var
a,b,h,x,y:real;
begin
a:=pi/4; b:=pi/2;
h:=(b-a)/(n-1);
x:=a;
while x<=b+h/2 do { h/2 - компенсация накопления погрешности }
begin
y:=2-sin(x);
Writeln(x:7:5,y:8:5);
x:=x+h
end
end.
Результат выполнения программы:
0.78540 1.29289
0.84150 1.25436
0.89760 1.21817
0.95370 1.18444
1.00980 1.15328
1.06590 1.12478
1.12200 1.09903
1.17810 1.07612
1.23420 1.05612
1.29030 1.03908
1.34640 1.02507
1.40250 1.01413
1.45860 1.00629
1.51470 1.00157
1.57080 1.00000