В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nika55551
nika55551
05.12.2020 03:07 •  Информатика

Составьте программу( на паскале) заполнения массива из 100 чисел,случайными значенииями из диапазона от -20 до 20 подсчитайте в этом массиве количество,положительных и отрицательных значений

Ответ:
Serey9999
Serey9999
19.07.2020 08:01
Const N = 100;
var a: array[1..n] of integer; i, countp, counts, countz:integer;
begin
for i := 1 to n do begin
a[i] := random( -20, 20 );
write ( a[i], ' ' );
if a[i] > 0 then inc(countp);
if a[i] < 0 then inc(counts);
if a[i] = 0 then inc(countz);
end;
writeln();
writeln('Количество положительных чисел: ', countp);
writeln('Количество отрицательных чисел: ', counts);
writeln('Количество нулей: ', countz); // выводим количество нулей (для проверки, что в сумме у нас 100 элементов)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?