В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
polinavlasenko4
polinavlasenko4
02.08.2021 04:59 •  Информатика

1)написать программу, которая определяет четной или нечетной является сумма чисел вводимого трехзначного числа.(учитель подсказал, что решается через if xmod=0) решите так, чтобы программа была решена не абы-как, а написана правильно и верно, чтобы программа паскаль читала ее на уроке.2)написать программу вычисления факториала числа. (типа 5! =1*2*3*4*5) заранее .

Ответ:
vikysik927
vikysik927
02.10.2020 09:10
№1
var chislo, sum: integer;
begin
repeat
writeln('Введите трехзначное число:');
readln(chislo);
until chislo in [100..999];

while chislo > 0 do
begin
sum := sum + chislo mod 10;
chislo := chislo div 10;
end;

if sum mod 2 = 0 then
write('Число четное')
else write('Число нечетное');
readln;

end.

№2

var factorial: longint; chislo, i: byte;
begin

chislo := 5;
factorial := 1;
for i := 2 to chislo do
factorial := factorial * i;
writeln('5! = ', factorial);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?