Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Robobob
01.02.2021 22:40 •
Информатика
Составьте блок-схему и напишите программу вычисления площади и гипотенузы прямоугольного треугольника, если известны его катеты.
Ответ:
ikurilo
02.10.2020 08:56
Var
a,b,c,z,p,r:real;
begin
writeln ('Введите катет А ');
readln (a);
writeln ('Введите катет B ');
readln (b);
z:=sqr(a)+sqr(b);
c:=sqrt(z);
writeln ('Гипотенуза равна ',c);
p:=(a+b+c)/2; {по формуле Герона нахожу полупериметр}
r:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln ('Площадь треугольника равна --> ',r);
end.
надеюсь блок схема понятна
0,0
(0 оценок)
Популярные вопросы: Информатика
Katylopy
07.10.2022 17:53
Массив из целых чисел от 1 до 100. выяснить количество чисел кратных 5 pascal...
valeriyaa17
04.05.2022 12:59
Межсимвольный интервал это: * расстояние между абзацами текстарасстояние между строками текстарасстояние между буквами текста !...
burtsevadianka
08.08.2022 14:24
Исправьте ошибки в приведенном фрагменте программного кода: program z1;var a,b:integer; c:real;begin a:=10; b:=1,7; c:=a+b;end....
вопрос210
21.10.2021 23:32
Найдите площадь квадрата, описанного около окружности радиуса 32. ответ:...
галина261
21.10.2021 23:32
Прямоугольник разбит на 4 маленьких прямоугольников двумя прямолинейными. периметры трёх из них начиная с левого-верхнего и далее по часовой стрелке равны: 12,15,16. найдите...
Nastenkapu
21.10.2021 23:32
Определите давление атмосферы в шахте на глубине h=240м, если на поверхности земли барометр показывает давление р1=101, 3кпа...
ррррррррор1
21.10.2021 23:32
На гоафике функции y=5x-8, найдите точку, абсцис которой противоположна её координате...
Romanus11
21.10.2021 23:32
Put the words in order to make questions live/does/near/andrew/you?...
sanya48481
21.10.2021 23:32
Как отличить водный раствор гидрокарбоната кальция, не имея никаких реагентов. нюхать и пробовать на вкус запрещено. опиши свои действия....
alsuu00
21.10.2021 23:32
Замените разговорное слово распекала...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a,b,c,z,p,r:real;
begin
writeln ('Введите катет А ');
readln (a);
writeln ('Введите катет B ');
readln (b);
z:=sqr(a)+sqr(b);
c:=sqrt(z);
writeln ('Гипотенуза равна ',c);
p:=(a+b+c)/2; {по формуле Герона нахожу полупериметр}
r:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln ('Площадь треугольника равна --> ',r);
end.
надеюсь блок схема понятна