В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Лиза0611
Лиза0611
24.12.2020 16:10 •  Информатика

Составить программу для решения : 1)даны действительные, положительные числа x,y,z. выяснить, существует ли треугольник с длинами сторон x,y,z. если треугольник, то является ли он равносторонним? 2)дан одномерный массив. найти количество смен знака между соседними элементами массива. программа -паскаль.

Ответ:
Sergovseznaet
Sergovseznaet
25.05.2020 22:27

var x,y,z:real;
begin
readln(x,y,z);
if (x<y+z) and (y<x+z) and (z<x+y) then begin
if (x=y) and (y=z) then writeln('Ravnostoronnii') else writeln('Ne ravnostoronnii');
end else writeln('Ne vozmojno sostavit');
end.

 

var a:array[1..10]of integer;
i,sum:integer;
begin
for i:=1 to 10 do readln(a[i]);
for i:=1 to 9 do begin
if (a[i]>0) and (a[i+1]<0) then sum:=sum+1;
if (a[i]<0) and (a[i+1]>0) then sum:=sum+1;
end;
writeln(sum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?