Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
MoDeRFeeD3
09.02.2023 00:41 •
Информатика
1.дан массив. все его элементы уменьшить на число а. 2.найдите произведение нечетных элементов массива в паскале , так что бы работало на компьютере и выдавала результат.
Ответ:
Theyom47
17.07.2020 21:26
Const n = 5;
var
a: array[1..n] of integer;
i, b: integer;
begin
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
end;
writeln();
read(b);
for i := 1 to n do
write(a[i] - b, ' ');
end.
const
n = 5;
var
a: array[1..n] of integer;
i, p: integer;
begin
p := 1;
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
if(odd (a[i])) then p *= a[i];
end;
writeln();
writeln(p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kayseriliadige
03.06.2023 19:00
Каков объем кислорода содержащегося в комнате размером a*b*c, если кислород составляет 21% объема воздуха ?...
Danil10031
03.06.2023 19:00
Вывести на экран меньшее из двух данных чисел x = 50 y=25...
ЕваЛя
03.06.2023 19:00
Найдите наименьшее для трех заданных чисел x y z....
pornuxa1
18.12.2022 21:34
Дан массив из 50 целочисленых элементав. Найьи элемента 20 и посчитать их количество...
katyaumnicka55
17.11.2020 12:38
Алгоритм следующих условий, на физкультуре вам задали бежать 5 кругов. Какой структуры будет данный алгоритм Алгоритм Сдаём кросс по физкультуре...
iweriooo
22.12.2020 02:59
Ограничение времени 1 секундаОграничение памяти 64MbВвод стандартный ввод или input.txtВывод стандартный вывод или output.txtСовременные генные инженеры создали 26...
Katerina20015
15.12.2021 10:42
Что такое информационная система? примеры информационной системы....
qwertyuiop342
15.12.2021 10:42
Записать в паскале.найти произведение всех цифр заданного четырехзначного числа....
g3force
04.04.2022 04:08
Самый современный информационный канал(8 букв)....
MAGNUSIK1
04.04.2022 04:08
Определите источник и приемник информации, а так же характер (односторонний, двухсторонний) передачи информации в следующих ситуациях: 1) завуч вывешивает листочек...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a: array[1..n] of integer;
i, b: integer;
begin
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
end;
writeln();
read(b);
for i := 1 to n do
write(a[i] - b, ' ');
end.
const
n = 5;
var
a: array[1..n] of integer;
i, p: integer;
begin
p := 1;
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
if(odd (a[i])) then p *= a[i];
end;
writeln();
writeln(p);
end.