В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
адевале1
адевале1
05.03.2021 21:49 •  Информатика

Надо составить программу для паскаль abc дано вещественное число.если оно отрицательное, вывести на экран его модуль, а если нет, то вычислить из него квадратный корень.

Ответ:
FreeSasha
FreeSasha
25.05.2020 21:54

var

  a: real; 

 

begin

  writeln('Введите вещественное число');

  readln(a);  //Вводим вещественное число

  if a < 0 then writeln('Модуль числа а: ', abs(a))  {Если введенное число - отрицательное, печатаем его модуль, иначе печатаем квадратный корень из этого числа с округлением до 5 знаков после запятой}

  else writeln('Квадратный корень из числа а: ', sqrt(a) : 0 : 5);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?