В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hmrl123
hmrl123
23.04.2020 05:54 •  Информатика

Написать программу генерирующую и выводящую на экран стозначное целое число.определить делится ли данное стозначное число на 3 или 9

Ответ:
NosoK535
NosoK535
25.05.2020 21:54

Program zadacha;

Var x:integer;

Begin

  Randomize;

  x:=random(9999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999)+1000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000;

  If (x mod 3=0) then begin

    If (x mod 9=0) then writeln('Делится на 3 и на 9);

  End;

  If (x mod 3=0) then begin

    If (x mod 9>0) then writeln('Делится только на 3);

  End;

  If (x mod 9=0) then begin

    If(x mod 3>0) then writeln('Делится только на 9);

  End; 

End.

 

 

P.S. Вы уверены, что СТОзначное число?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?