В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности 1, 2, 4, 8, 16, 32. в первой строке содержится n (1 ≤ n ≤ 50) – количество чисел. вывести первые n чисел прогрессии со знаменателем 2 и первым членом 1. с++

Ответ:
ruks777
ruks777
17.07.2020 10:51
#include <stdio.h>

int main()
{
int n, i;
scanf("%d", &n);
if (n>=1&&n<=50)
{
for (i=1; i<=n;i*=2){
printf("%d ", i); }
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?