Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Камила77
16.01.2023 22:37 •
Информатика
Напишите программу решения любого квадратного уравнения. заранее!
Ответ:
Мишка12лэд
17.07.2020 09:18
#include <stdio.h>
#include <math.h>
int main()
{
int a,b,c,D,x1,x2;
scanf ("%d %d %d", &a, &b, &c);
printf("%dx^2%dx%d=0\n", a,b,c);
printf("D=b^2-4ac=%d\n",b*b-4*a*c);
D=b*b-4*a*c;
if (D<0) printf("Net resh");
if (D==0) printf("x=-b/2a=%0.2f", -0.5*b/a);
if (D>0) {printf ("x1=(-b+sqrt(D))/2a=%0.2f \n", 0.5*(-b+sqrt(D))/a);
printf ("x2=(-b-sqrt(D))/2a=%0.2f \n", 0.5*(-b-sqrt(D))/a); }
return 0;
}
0,0
(0 оценок)
Ответ:
MostQweek
17.07.2020 09:18
Java
исходник прикреплен (424 строк кода), основной плюс в том что этот алгоритм сокращает дроби, однако это бета, не совсем правильно иногда.
и еще корень не очень хорошо вычисляет
0,0
(0 оценок)
Популярные вопросы: Информатика
ssshhhhhhannnnssha
14.01.2023 19:39
Объясните как это решать)) в программе «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления....
vilortnt
14.02.2021 07:16
Как называется функция, которая может быть вызвана самим телом функции? ...
незнайка1186
02.01.2021 13:05
Входе расследования полиция скотланд-ярда выяснила номер дома(12010) и номер квартиры (210012) преступника. но на указанной улице не нашлось дома с таким номером. от безысходности...
sonya76557
12.07.2021 09:54
Прочитайте ниже текст, каждое положение которого пронумеровано. (1) общество — продукт совокупной деятельности множества людей. (2) не случайно древнегреческий философ аристотель,...
Птичка220903
12.07.2021 09:54
:установите соотвестие 1.местоимение. 2. наречие и местоименное наречие a)бок о бок b)какая-то с)когда-то d)кое о ком варианты ответа: a. 1bc, 2ad b. 1bd, 2ac c. 1ab, 2cd...
Zomka1
12.07.2021 09:54
Тождественные преобразования рациональных дробей сократить: (а+2 а-2) а^2+4 + : (а-2 а+2) 4-a^2 обязательно с решением!...
parus27
12.07.2021 09:54
Проведите лингвистическое исследование.выясните этимологию вашего имени,установите,что оно озночает. дополните ваше иледование сведиями о том, нравиться ли оно вам ,чувствуите...
Kamaria086
12.07.2021 09:54
Масса глухаря равна 3 кг 200 г и составляет 2/5 массы лебедя .масса чайки составляет 3/32 массы лебедя и 3/5 массы утки . вычислите массу каждой птицы ....
Nessmikk13
12.07.2021 09:54
Вычислить все что можно вычислить.решить в 2 ! тарас разместил 30 новых марок на 5 альбомных листах....
bubles13
12.07.2021 09:54
Скакими из перечисленных веществ может вступить во взаимодействие серная кислота, находящаяся в водном растворе: оксид магния, хлорид бария, серебро, оксид углерода (iv),...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <math.h>
int main()
{
int a,b,c,D,x1,x2;
scanf ("%d %d %d", &a, &b, &c);
printf("%dx^2%dx%d=0\n", a,b,c);
printf("D=b^2-4ac=%d\n",b*b-4*a*c);
D=b*b-4*a*c;
if (D<0) printf("Net resh");
if (D==0) printf("x=-b/2a=%0.2f", -0.5*b/a);
if (D>0) {printf ("x1=(-b+sqrt(D))/2a=%0.2f \n", 0.5*(-b+sqrt(D))/a);
printf ("x2=(-b-sqrt(D))/2a=%0.2f \n", 0.5*(-b-sqrt(D))/a); }
return 0;
}
исходник прикреплен (424 строк кода), основной плюс в том что этот алгоритм сокращает дроби, однако это бета, не совсем правильно иногда.
и еще корень не очень хорошо вычисляет