В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kostya2031
kostya2031
21.04.2020 09:35 •  Информатика

3. написать программу вычисления xy, не используя функцию возведения в степень (только цикл). x,y вводятся с клавиатуры

Ответ:
Ivanlabur
Ivanlabur
17.07.2020 07:25
Тривиальное решение.

var
  i,r,x,y:integer;
begin
  Write('Вычисление х в степени y, введите х,y: ');
  Readln(x,y);
  r:=x;
  for i:=2 to y do r:=r*x;
  Writeln('Результат: ',r)
end.

Тестовый прогон:
Вычисление х в степени y, введите х,y: 2 10
Результат: 1024

Вариант для любителей начинать циклы с единицы.
var
  i,r,x,y:integer;
begin
  Write('Вычисление х в степени y, введите х,y: ');
  Readln(x,y);
  r:=1;
  for i:=1 to y do r:=r*x;
  Writeln('Результат: ',r)
end.
0,0(0 оценок)
Ответ:
Vgenika
Vgenika
17.07.2020 07:25
Var x,y,p:integer;
begin
read(x,y);
p:=x;
for y:=y downto 2 do
  p*=x;
writeln(p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?